View Single Post

Old 06-09-2007, 11:38 AM
timsalmon's Avatar
timsalmon timsalmon is offline
Super Moderator
Join Date: Mar 2006
Location: Chichester
Posts: 363
timsalmon is on a distinguished road
E90 & Belkin Router: Solution to 'No Gateway Reply'

Having fought with this well reported problem almost since day one, I thought I'd post the solution that has now worked for me. I have a Nokia E90 (and an E70) and Belkin ADSL Modem with Wireless-G Router (54). When I first got the E90 it 'saw' the (unsecured) network no problem, and connected. Some time after that (and maybe since I took the E90 to work and hooked it up no problem with the Linksys Router there - no security) it just continued to report 'no gateway reply' every time I tried to connect. I trawled the forums and followed what advice I could find, but didn't get anywhere. All this time, the E70 went straight on - no problem - all the settings in the two phones were the same, but the E90 just kept reporting the error. I tried hard-resetting the E90 (full 3+*+green+power) but still no joy. I tried this because some dipstick at Belkin support told me that I had screwed the phone by confusing it with the network at my workplace (?!?). Anyway, no joy.

So I started fiddling and after ages, made it work by going into the Belkin Setup, checking free IP addresses when clicking on LAN Setup/DHCP Client List (from left menu) and making a note of the ones which are already used - you need to use an unused one. In LAN Setup/LAN Settings you'll see the Subnet Mask - make a note. You'll also find here the 'default gateway' but it's just called IP Address - make a note. Then in Internet WAN/DNS you'll find the Primary DNS and Secondary DNS settings - make a note.

Turning to the phone, open settings/connection/Access Points then open up the 'Belkin54g' Access Point for editing... Connection name: Belkin54g, Data Bearer: Wireless LAN, WLAN network name: Belkin54g, Network status: Public, WLAN network mode: Infrastructure, WLAN security mode: Open network. Then Options/Advanced Settings/IPv4 settings - Phone IP Address: try an address that you identified earlier wasn't being used, Subnet mask: what you made a note of, Default gateway: you noted it. Highlight and select DNS address, then put in your primary and secondary DNS addresses as you noted earlier.

Now I've seen all this information elsewhere on the forums, but not specifically for the Belkin and I could have used this to help me. The stuff I read assumed a knowledge of matters networking, which I don't have. So I hope this helps someone else before Nokia decide to fix this problem which seems to be pretty widespread. I did try a NSU on the phone but it said it had the latest version, incidentally.

For the record, I turned on the WEP security after I'd got it all working and it worked OK, then the next morning it failed again, so I'm not sure what that's about. At the moment I have no security on. I know I should have and I'll play with that but - it's working!