All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

  #1  
Old 06-11-2010, 07:13 PM
busychild busychild is offline
Registered User
 
Join Date: Nov 2010
Posts: 1
busychild is on a distinguished road
Nokia 5800 Screen Problems After Firmware Update V51.2.007 RM-428

Hi all,


I have the Nokia 5800 navigation edition. I just updated the firmware on it from V40. to the latest available 51.2.007. Doing so has turned the phone's screen into a huge mess - the lower half of the screen is all white and the upper half has some weird flickering and the icons(the ones that are visible) are all messed up too and some of them are not responding at all.


Heres what I've done to resolve the problem:


- remove the battery, memory and sim cards for a few hours.


- reboot the phone without the memory card(eliminating any corrupt setup files).


- reinstalled the V51.2.007 update several times using both the Ovi Suite and the older Nokia PC Suite updater.


- tried running the updates on all XP, Vista and Windows 7.


Can you please advise me of any other possible solutions I can try. Is there any way to revert back to the older firmware. The phone was working just fine before the update.

Thank you all for your help.

  #2  
Old 13-11-2010, 11:45 AM
KenBruce KenBruce is offline
Registered User
 
Join Date: Jan 2007
Posts: 46
KenBruce is on a distinguished road
Have you tried the *#7370# for re formatting or can you not type anything on the phone?

  #3  
Old 13-11-2010, 01:18 PM
jApi NL's Avatar
jApi NL jApi NL is offline
Registered User
 
Join Date: Dec 2008
Posts: 1,146
jApi NL is on a distinguished road
Smile Hardware Issue ?

It can be a Hardware issue as well . Such as broken screen or an electrical shortcut , maybe due to water , moist ? Or a stuck hardware button ?
In case of moist , have it dried some days in a bag of rice , in sunshine or use a hairdryer .
Here are threads about a hard reset , using the hardware buttons :
-- Hard Reset N97 / 5800
http://www.allaboutsymbian.com/forum...ad.php?t=86049
-- Hard Reset 5800
http://www.allaboutsymbian.com/forum...ad.php?t=83395

Regards jApi NL
Ads

  #4  
Old 09-12-2010, 06:03 PM
rcsammy rcsammy is offline
Registered User
 
Join Date: Dec 2010
Posts: 1
rcsammy is on a distinguished road
Hi, new here, just found this via Google

I just updated the firmware on my 5800 and am experiencing the exact same screen problems as Busychild

That would make me think that it is not a hardware problem? the phone was working perfectly right up to the moment of installing the new firmware

I have tried restarting it without sim and memory card and tried a reset by holding green+red+camera and turning it on but nothing made any difference.

Any help?
Cheers
 

Bookmarks

Tags
5800, firmware, nokia, problems, rm428, screen, update

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[HOT][NEW] N80 RM-92 IE APAC PR v15.00 SW4.0632.0.38 juato4 Nokia N80 176 25-04-2007 03:19 PM



All times are GMT. The time now is 07:45 AM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy