All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

  #16  
Old 22-08-2006, 07:42 AM
sunlie sunlie is offline
Registered User
 
Join Date: Jun 2006
Posts: 10
sunlie is on a distinguished road
Quote:
Originally Posted by matt_storr
So can any1 shed any light on how to import server root certs then? We have a self-signed root cert on our Windows 2003 server where Exchange is installed. I access the site, double click the secure lock icon and copy the cert to my desktop as a DER formatted cert. I then proceed to copy the .cer cert over to my E61 but it wont open it saying unknown format. I copy the same cert to my N70 and it installs fine.

I've used OpenSSL to copy to and from PEM to DER format - still no joy. Could it be that there is something wrong with self certified root certs created using Windows Certification Server?
matt_storr, have you try putting the OpenSSL converted certificate to your website root directory and access it using the E61 built in web browser ? In my case this is the only way I can install the certificate.

  #17  
Old 22-08-2006, 08:13 AM
karlossus karlossus is offline
Registered User
 
Join Date: Jun 2006
Posts: 3
karlossus is on a distinguished road
Sunlie, could you post the conversion process step by step please? Just so there's a record of how it's done. Thank you.

  #18  
Old 23-08-2006, 01:18 AM
sunlie sunlie is offline
Registered User
 
Join Date: Jun 2006
Posts: 10
sunlie is on a distinguished road
karlossus, here's how I do it :

- export the .cer certificate
- use OpenSSL to convert the certificate to .pem, using the command : openssl x509 -inform der -in MYCERT.cer -out MYCERT.pem
- convert the .pem to .der using command : openssl x509 -outform der -in MYCERT.pem -out MYCERT.der
- copy the .der cetificate to the website root directory (recommended) or copy it to a newly created directory
- set the directory MIME types to application/x-x509-ca-cert for .der extension
- browse the file using the E61 built in web browser, the certificate will install automatically

From all possible ways, this is the only way I can get the certificate installed on my E61, hope it's helpfull.

  #19  
Old 23-08-2006, 11:10 AM
karlossus karlossus is offline
Registered User
 
Join Date: Jun 2006
Posts: 3
karlossus is on a distinguished road
Thanks Sunlie, those are great instructions. However it still hasn't worked for me. As always the certificate appears in the User folder of the certificate manager and not in the CA folder. Then Activesync still always asks if I trust the Exchange server (I do I do).

There must be a bug somewhere which isn't allowing me to trust the certificate properly.

It's a P990i I am trying to set up though both it and the E61 are the same version of symbian.

Thanks for your help again Sunlie.

  #20  
Old 06-09-2006, 07:39 PM
elaverick elaverick is offline
Registered User
 
Join Date: Nov 2002
Posts: 150
elaverick is on a distinguished road
Sorry for the thread archaeology, but a thought occurs to me having spent a long day playing with this myself.
What are the subjects of these failed certificates? Mine appears to be listing the internal domain (.local) rather than the domain the device thinks its connecting to (.com)
If I could figure out how to recreate the certificate for the external domain I'd test the theory but I don't know how to do that just yet...

Any thoughts?

  #21  
Old 10-10-2006, 07:14 PM
chucksrover chucksrover is offline
Registered User
 
Join Date: Oct 2006
Posts: 1
chucksrover is on a distinguished road
Worked...only place on the web-

Sunlie-

This is the only place on the web where I've found proper directions to get this installed. I have an e62, and I've tried copying, sending, emailing the .der certificate without luck. It will not recognize the file format.

The only option was to publish or copy this to a directory on your exchange server website, with the proper MIME type added for the .der file type.

Thank you!!

  #22  
Old 12-10-2006, 08:09 PM
bjornhij bjornhij is offline
Registered User
 
Join Date: Oct 2006
Posts: 1
bjornhij is on a distinguished road
Karlossus, I have the same problem you have. The certificate appears in the 'user' folder, not the 'CA' folder. Did you find a solution yet?

Thanks,
Bjorn

  #23  
Old 13-10-2006, 11:09 AM
desertrat desertrat is offline
Registered User
 
Join Date: Sep 2006
Posts: 122
desertrat is on a distinguished road
Quote:
Originally Posted by bjornhij
Karlossus, I have the same problem you have. The certificate appears in the 'user' folder, not the 'CA' folder. Did you find a solution yet?
Are you sure you're importing the CA's (Certificate Authority's) certificate and not the server's certificate?
Ads

  #24  
Old 23-10-2006, 11:46 AM
jventura jventura is offline
Registered User
 
Join Date: Sep 2006
Posts: 1
jventura is on a distinguished road
Import Server certificate to N80

Hello,

I've seen your comments in the forum and after following forum's indication was able to install the certificate to my N80 (S60 3rd ed) but it continues to ask for confirmation whenever I access the webpage.

Any ideas?

Thanks,

NOTE: I can find ther certificate in my N80 Certificate folder...

Joao Ventura

  #25  
Old 25-10-2006, 11:44 AM
pelwell pelwell is offline
Registered User
 
Join Date: Feb 2004
Posts: 92
pelwell is on a distinguished road
Possible fix

You will have to forgive me if my terminology is a little off, I am not fully conversant with all this.

I recently had to get an E61 working with an Exchange email server and hit the request to accept the certificate problem when it synchronised. I tried many of the above suggestions to no avail. I have fixed it though, and learnt a few things along the way.

What I didn't realise is that there are 2 certificates involved in the process. The 1st is what I will call the "root certificate" created on my Windows 2003 server, it has a 5 year life span. The 2nd is what I will call the "client certificate". The client certificate is a child, for want of a better word, of the root one.

I found that the only certificate I could install on the E61, by copying the .cer file across with no conversion necessary, was the root certificate. All others were rejected. Installing this made no difference to the acceptance request when syncing. The syncing, or web-browsing process, calls the client certificate and it not seen as trusted, hence the prompt.

The fix I found was to tell the E61 to trust my root certificate. Here's how:

Menu - Settings - Security - Certif. management

Find your root certificate (xyzCA in my case) in the list. Options - Trust settings. Set "Internet" and "Online certif. check" to Yes.

Hopefully now when you sync the client certificate will be trusted, because the root one is seen as a trusted source.

  #26  
Old 25-10-2006, 07:36 PM
agerbo agerbo is offline
Registered User
 
Join Date: Oct 2004
Location: DK
Posts: 1
agerbo is on a distinguished road
@pelwell

Where did you copy your .cer file to on your E61

/agerbo

  #27  
Old 26-10-2006, 08:30 AM
pelwell pelwell is offline
Registered User
 
Join Date: Feb 2004
Posts: 92
pelwell is on a distinguished road
I just copied the file across, via USB, to the Documents folder, though any folder will do.

  #28  
Old 17-11-2006, 09:46 AM
rolexel rolexel is offline
Registered User
 
Join Date: Nov 2006
Posts: 1
rolexel is on a distinguished road
The process is simple, and i just got my email client to work with my imap server.

Just send the .cer file to the phone, and open Certificate Manager in Tools. Then, add this .cer file. Once you added, select it, and hit View Details, and then Trust Settings. MAKE SURE email and web browsing is set to 'yes'. This will allow your email clients to trust the corresponding imap server and stop asking you repeatedly about accepting certificates!

  #29  
Old 18-12-2006, 03:46 AM
dobermann dobermann is offline
Registered User
 
Join Date: Dec 2006
Posts: 2
dobermann is on a distinguished road
E62 - can't get it to recognize certificates

Hi all. I've been trying to get exchange server to work with my E62, and its been a struggle. Although i'm a bit over my head here, i'm trying to learn and have found the forum helpful.

So here's where I am:

Have 2 certificates from my admin (who says on my own since not a windows device) ROOT Certificate.cer and EXPORTED owa.hedhifi.com SSLcertificate.cer that I have transferred to phone via USB into a cert file i created.

As far as i can tell, there isn't a way to add the files using certificate manager. The manager only shows the files that exist on the phone, and won't allow me to browse to the new ones.

The phone just keeps saying "can't open file" or "unknown file type" so it won't allow me to take any action.

I could try to download the file directly as some in the forum have suggested, but others say it works fine to manually transfer.

Does anyone have any suggestions? Any help would be appreciated, I really need to get this figured out...

Cheers.

  #30  
Old 26-12-2006, 11:24 PM
dobermann dobermann is offline
Registered User
 
Join Date: Dec 2006
Posts: 2
dobermann is on a distinguished road
Can anyone help me out with this? I haven't been able to make any progress, and can't find information elsewhere...

Thanks.
 

Bookmarks

Tags
certificate, e61, import, server

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MAIL: N70 / TLS (IMAP/SMTP) W/Self Signed Certificate -hicks- Nokia N70, N72 and N90 0 05-04-2006 08:10 PM
Nokia Licence MS Exchange Server Active Sync Technologies Ewan Symbian OS News 0 14-02-2005 08:38 AM
Image-Uploader works with my own Server! Try it for yourself projektil Nokia 7650 25 03-12-2002 10:30 AM



All times are GMT. The time now is 12:07 PM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy