All About Symbian - Nokia (S60) and Sony Ericsson (UIQ) smartphones unwrapped

  #1  
Old 22-03-2007, 09:53 PM
Emo185's Avatar
Emo185 Emo185 is offline
Registered User
 
Join Date: Mar 2007
Location: Worksop, UK
Posts: 59
Emo185 is on a distinguished road
N80 Problems - Sim Card Registration Failed

Hi, im new here (if you haven't noticed) well i've browsed around the forums and looked for a solution but i could not find one (maybe i didn't try hard enough im not sure).

Anyway.......I recently got an N80 from ebay (came through post today) anyway asked Orange REP asking whether or not a normal Pay and go simcard would work in a previously contracted N80 phone (she said yes - so thats ok, but that aint the problem im having).

The Problem is this.....When i inserted my normal Orange Pay As You Go Sim Card it would boot up fine and give me "connection error" or possibly a "Sim Failed", however it would still lock onto Orange and give me a Signal. I could send text messages, but i could not recieve text messages or make / recieve phone calls.

I thought this might be due to not having a 3G Sim Card - so i dug out a Orange Simcard i got with my moms Nokia 6630 (3G Sim card) i logged onto my orange account and clicked on "Upgrade account" entered in my new Sim Card Number and IMEI Number (from N80) and everything went through fine.

Well i put the simcard into the N80 and it switch it on and it still says "Sim Registration Failed", so i insert my old sim card in and it says "Sim Registered Failed", i put my new sim card into my N-Gage QD it says "Sim Registration Failed", i insert my old sim card into my N-Gage QD and it works fine, i insert my old sim-card into my N80 and it says Sim Failed" but still connects to the orange service.

i know that was abit long, but i thought id give you all the details........so does anyone know whats going on or what i should do?
thanks in advance.

  #2  
Old 22-03-2007, 10:49 PM
bbracer16valver's Avatar
bbracer16valver bbracer16valver is offline
Registered User
 
Join Date: Jan 2007
Location: stroud, gloucestershire
Posts: 249
bbracer16valver is on a distinguished road
Sim Registration Failed

means

1, you got a sim card that is expired ie: been on the self to long so the number was disconneted and asigned elsewhere, then the sim will work in no other phone

2, Sim Registration Failed means simply you have a blocked/locked phone and have been conned

if theres a third let me no

  #3  
Old 23-03-2007, 07:49 PM
Burcrim Burcrim is offline
Registered User
 
Join Date: Oct 2004
Location: New Jersey
Posts: 105
Burcrim is on a distinguished road
This maybe a third reason - not sure what's causing it though as the phone works fine.

But ever since the last firmware upgrade several months ago I sometimes get "SIM registration failed" whenever I lose signal. When I get the signal back I stop getting the error messages!

  #4  
Old 23-03-2007, 09:41 PM
kontraband's Avatar
kontraband kontraband is offline
Super Moderator
 
Join Date: Jul 2006
Posts: 2,666
kontraband is on a distinguished road
the SIM reg failure normally comes from it being lock to a service provider, or the sim has expired.

Last edited by kontraband; 21-05-2009 at 07:26 PM.
Ads

  #5  
Old 24-03-2007, 06:55 PM
Emo185's Avatar
Emo185 Emo185 is offline
Registered User
 
Join Date: Mar 2007
Location: Worksop, UK
Posts: 59
Emo185 is on a distinguished road
Ok i went down to the orange shop today and old him what happens - he said it must be because i need an updated sim-card, so i purchased a brand new orange sim card for £5.

When i got home i rang up orange and registered my details and my phone with that sim-card (aswell as changing my old sim-card to the new one) - they did ask, why am i updating again when i updated 2 days ago i said it was a dead sim card.

Anyway she said to me i should insert me sim-card into the N80 and within 24hrs i should recieve some text messages etc....then the phone should fully work (so all im doing now is waiting).

So far the phone is working HOWEVER when i have it in DUAL MODE my connection drops after a few minutes, so ive switched over to GSM mode...and the phone is working ok.

But im still getting the "Sim Card Registration Failed" message when i switch on my phone and the Connection Error message when i try ringing someone. Yet i have a strong signal and connected to orange network.

guess i should wait till tomorrow afternoon and see what happens?

  #6  
Old 24-03-2007, 08:32 PM
Emo185's Avatar
Emo185 Emo185 is offline
Registered User
 
Join Date: Mar 2007
Location: Worksop, UK
Posts: 59
Emo185 is on a distinguished road
*UPDATE*

hmmm looks like i have been conned and i presume the phone has been blacklisted (done some rea-search).

Apparently when interesting a sim-card into a black-listed phone it will come up "Sim Registration Failed" and give you no signal, however in my case it came up Sim Registation Failed but gave me full signal and signed onto Orange Network. But blacklisting doesn't let you ring out (or recieve calls).....which i can't do, however i can send text messages but i can not recieve them.

So i interested my new sim-card back into my N-Gage QD and everything works fine (no errors) so im "presuming" ive bought a blacklisted N80 :(

Looks like i'll try and resolve it with the seller / ebay / paypal as he did not state anything like that in the auction and i asked him about any blocks on the phone aswell.

  #7  
Old 18-04-2007, 04:04 PM
kontraband's Avatar
kontraband kontraband is offline
Super Moderator
 
Join Date: Jul 2006
Posts: 2,666
kontraband is on a distinguished road
well if you did buy a blacklisted one... i.e. a stolen one, and ebay dont help... the fuzz probably will!

  #8  
Old 26-06-2007, 02:34 AM
huangtow huangtow is offline
Registered User
 
Join Date: Jun 2007
Posts: 1
huangtow is on a distinguished road
nokia 5500 sim failed to register

so i'm new here as well. i thought i might try here to get some help with my series 60 phone. i just got a 5500 bout a month ago. it's been working fine and one day in the morning i used it a couple times but all through out the day it was silent so after work i looked a the phone and it said "sim registration failed"

i thought to mess around with it when i got home and when i sat down at the table with it things went back to normal. i tried outgoing calls and it was fine. then bout 5 mins later, it failed again. and now periodically it'll send me the "sim registration failed" message and otherwise just has a black spot where the provider title would be and no bars of reception.

this is a new phone, not blacklisted or stolen or anything like that. and i'm having terrible trouble getting nokia to help me out with warranty because i live in the United States and the phone was never released here. Booooo for Nokia on that one. They tell me no USA warranty and to call the country it came from, so I contact Nokia China and they sorry no international warranty. Their product is a product, no matter where in the world its from right...i dunno. if anyone has any comments or suggestions i'm all ears. thanks for reading.

  #9  
Old 26-06-2007, 07:57 AM
Steve_R's Avatar
Steve_R Steve_R is offline
Registered User
 
Join Date: May 2007
Location: Warwickshire, England
Posts: 262
Steve_R is on a distinguished road
I used to have this problem on my old E61 occasionally. It was the SIM not quite seated properly.

Its a long shot, but may be worth a go
__________________
M'Blog - http://thenokianetwork.com/

Frustrated Nokia fan, running an old skool E71

Follow Me on Twitter

  #10  
Old 26-06-2007, 02:51 PM
dhevans_6 dhevans_6 is offline
Registered User
 
Join Date: Mar 2007
Posts: 66
dhevans_6 is on a distinguished road
Quote:
Originally Posted by Steve_R View Post
I used to have this problem on my old E61 occasionally. It was the SIM not quite seated properly.

Its a long shot, but may be worth a go

I've had the same problems with my N80, which I've had from new. Sometimes cleaning the SIM helps, sometimes just a reboot, but a couple of times I've had to go as far as reinstalling the current firmware for my phone which was very annoying...

  #11  
Old 26-06-2007, 03:38 PM
trendsbze trendsbze is offline
Registered User
 
Join Date: Jun 2007
Posts: 33
trendsbze is on a distinguished road
I am having the same problem with getting my N80IE serviced in the States where it was purchased. Before I made the purchased, Nokia advised me that their phones cane with international warranties, which I find out isn't true. I am now stuck with a 6 week old brick. Luckily I purchased it with my credit card and If the store will not repair or replace it, the credit card co. will give me back my money. I would advise anyone buying a Nokia in this part of the world to use a credit card. Nokia sucks big time when it comes to warranty and support in the western hemisphere.

  #12  
Old 26-06-2007, 04:29 PM
Burcrim Burcrim is offline
Registered User
 
Join Date: Oct 2004
Location: New Jersey
Posts: 105
Burcrim is on a distinguished road
I used to get this all the time when i lost reception, however since upgrading to the v5 firmware i've not yet seen it!

  #13  
Old 27-06-2007, 07:28 AM
jet2006 jet2006 is offline
Registered User
 
Join Date: Jun 2007
Location: uk
Posts: 12
jet2006 is on a distinguished road
sim info

If u get sim reg failed or words to that effect, then that particular sim has been deactivated by the operator, best is to get a new sim, and register it, and obviously fit it in sim socket carefully.

Check your network settings and also set phone to GSM from phone settings menu.

For a try use a sim that is already active and one that the phone is locked on.

IF there is a hardware issue then an active sim not working in phone should arouse problems in that direction, but initially look at software then hardware issues and eliminate fault that way.

On a blocked phone u will get no signal in/out.
 

Bookmarks

Tags
card, failed, n80, problems, registration, sim

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can I use N-Gage QD without SIM card ?? sli Nokia N-Gage and N-Gage QD 5 31-08-2009 06:37 AM
Sim card registration failed voki Nokia N70, N72 and N90 10 18-08-2009 09:19 AM
Cingular in US, will 64 meg sim card work? flipwils11 Siemens SX1 2 15-12-2005 10:33 PM
Signal problems with Cingular and 6670 o_xx_o Nokia 7610 and 6670 2 28-10-2005 03:05 PM
7610: Insert SIM Card.. error inferno2k3 Nokia 7610 and 6670 1 17-10-2005 02:57 PM



All times are GMT. The time now is 07:03 AM.


vBulletin skins developed by: eXtremepixels
Powered by vBulletin® Version 3.8.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright Notes || Contact Us || Privacy Policy